Status
Get in touch
Back
Resolved
[DOWNTIME] Disk Storage Outage on 6 February 2025
Started 6 Feb at 10:15pm PST.
Affected services
forum.pianotell.com
Created
PianoTell was down for 29 minutes. Click here for details.
Posted 6 Feb at 10:15pm PST.